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Tutorial Sessions - Using Simupedia Studio with Simantics System Dynamics

Tutorial 1 – Basic System Dynamics Modelling
This tutorial will introduce you to the basic components and concepts of the Simantics System Dynamics
modelling tool. After completing this tutorial you will know how to configure and simulate a system
dynamics model.

Install and Run Simantics System Dynamics
1. Unzip the Simantics System Dynamics archive on your hard drive. Make sure that you have full
write permissions to this path.
2. Launch Simantics-Sysdyn application.
3. Select a folder for the workspace.

Create a New Model
We will create a model that simulates discovery and exploitation of natural resources. The model is based
on Bossel, Hartmut (2007). System Zoo 2 Simulation Models. Climate, Ecosystems, Resources. BoD.
First we create a new Model.
1. Right-click on the Model Browser and select “New -> Model”.

Alternatively you can create a new Model by selecting “File -> New -> SD Model”.
Then we rename the model.
1. Right click on Model and select Rename.
2. Rename the model to Discovery And Exploitation Of Resources.
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Configuration
First we set the general properties of the model.
Select Discovery and Exploitation of Resources in the Model Browser and open the Selection view.
1.
2.
3.
4.

Set Stop time to 200.0.
Set Step length to 0.125.
Check the “Validate units” checkbox.
Set the time unit to “year”.

Draw the Diagram
Next we prepare the workspace.
1. Double-click on Configuration in Model Browser. The model configuration diagram will open in a
new editor. Initially the diagram will be empty. Press G to enable/disable grid on diagram.
2. Open the “Symbols” view and expand BasicSymbols and CommentSymbols. Here you can find the
symbols that we will be using in the diagram.
You can zoom in/out in the diagram by using the mouse wheel or +/- keys. Panning is possible by holding
the middle mouse button or by using the arrow keys.
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Stocks
Next we include two stock variables into the model.
1. Drag a Stock symbol from BasicSymbols to the diagram.
2. Rename the stock to Discovered Resources.
3. Likewise create a second Stock and rename it to Consumed Resources.

You can adjust the shape of the text area by dragging if from the borders.
Flows
Next we add flows into stock variables.
1.
2.
3.
4.
5.

Drag a Cloud symbol from BasicSymbols to the left side of Discovered Resources stock.
Hold down Alt and right-click on the Cloud.
Left-click on top of Discovered Resources stock.
Rename the newly created valve to Discovery.
Likewise create a flow into Consumed Resources stock and rename its valve to Consumption.

Auxiliary Variables
Next we add two auxiliary variables to the model.
1. Drag two Auxiliary symbols from BasicSymbols to the diagram.
2. Rename the variables to Discovery Effort and Available Resources.
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Parameters
Next we add six parameters to the model.
1. Drag six Auxiliary symbols from BasicSymbols to the model (we later set their type to parameter).
2. Rename the variables to MAX DISCOVERABLE RESOURCES, MAX DISCOVERY RATE, INITIAL
DISCOVERED RESOURCES, RECYCLED RESOURCE SHARE, MAX CONSUMPTION RATE and INITIAL
CONSUMED RESOURCES.

Dependencies
Next we draw dependencies between the variables.
1.
2.
3.
4.

Hold down Alt and left-click the source variable.
Left-click the target variable.
Adjust the curvature by dragging the arrow with left mouse button pressed down.
Select the dependency arrow and adjust the polarity of the dependency at the Selection view. This
is optional and won’t affect the outcome of the simulation.

Add all the dependencies according to the following diagram.
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Loop
Next we add a Loop symbol to indicate the balancing loop in the model. This is again only a visual cue.
1. Drag a Loop symbol from CommentSymbols to the diagram inside the loop consisting of Discovered
Resources, Available Resources, Discovery Effort and Discovery variables.
2. Select the Loop and open the Selection view.
3. Find the correct loop from the Loop Items dropdown menu.
4. Set Direction of Rotation to Counterclockwise.

Title
Finally we add a title for the diagram.
1. Drag a Comment symbol from CommentSymbols to the diagram.
2. Change the title to Discovery And Exploitation Of Resources.
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Enter Equations for the Variables
As the last step we define equations for the variables. To edit the properties select the variable and open
the Selection view.
Tip: You can select previously entered Units from the dropdown menu.
Enter the properties for stock variables according to the following table.
Name
Consumed Resources
Discovered Resources

Unit
Mio t
Mio t

Integral
Consumption
Discovery

Initial Value
INITIAL CONSUMED RESOURCES
INITIAL DISCOVERED RESOURCES

Enter the properties for auxiliary variables according to the following table.
Name
Available Resources
Consumption

Unit

=

Mio t

Discovered Resources - Consumed Resources

Mio t / Year

Discovery

Mio t / Year

Discovery Effort

1

(1 - RECYCLED RESOURCE SHARE) * MAX CONSUMPTION RATE
* Available Resources
MAX DISCOVERY RATE * Discovered Resources * (1 (Discovered Resources / MAX DISCOVERABLE RESOURCES)) *
Discovery Effort
1 - (Available Resources / MAX DISCOVERABLE RESOURCES)

Enter the properties for parameters according to the following table. The type of the variable will change
automatically to Parameter after entering a constant value to its equation.
Name
INITIAL CONSUMED RESOURCES
INITIAL DISCOVERED RESOURCES
MAX CONSUMPTION RATE
MAX DISCOVERABLE RESOURCES
MAX DISCOVERY RATE
RECYCLED RESOURCE SHARE

Unit
Mio t
Mio t
1/Year
Mio t
1/Year
1

=
0
0.01
0.1
1
0.1
0

Run the Simulation
The model is now finished. If you still see red/yellow exclamation icons next to the variables, there are
errors/warning related to them. You can see the details in the Issues view. If everything is ok, it’s time to
run the simulation.
1.
2.
3.
4.
5.

Expand Experiments at Model Browser -> Discovery And Exploitation Of Resources.
Double click on Experiment to activate the experiment.
Click the Simulate Button.
Open the Trend view.
Select a variable at the model configuration diagram to see its time series in the Trend view.
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Tutorial 2 – Simupedia Basics
This tutorial will teach you how to create a simple web page for running System Dynamics experiments
using the Simupedia Studio. The end-user will be able to adjust the values of the parameters and to see the
results of the simulation in line charts.

Install the Simupedia Plug-in
First the Simupedia Studio plug-in needs to be installed from Update Site. Select from Main menu “Help ->
Install New Software…” to start installation. Click “Add…” and enter the Simupedia update site location
https://www.simantics.org/update/simupedia/1.0
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The category “THTH Member Components” appears. Expand it, select “Simupedia Workbench” and click
Next, click Next, accept the license agreement and click Finish.
There will be a security warning about unsigned content. Continue the installation by clicking OK. After the
installation process has finished restart the software as requested.

Import the Simupedia Shared Library
We will be using widgets from the Simupedia shared library in this tutorial, so first we import the Simupedia
shared library to the workspace. File SysdynSimupedia.sharedLibrary can be downloaded from
http://www.simupedia.com.
1. Right-click on the Model Browser and select “Import -> Shared Library”.
2. Locate the downloaded SysdynSimupedia.sharedLibrary and click Open.
Alternatively you can import the shared library by selecting “File -> Import Shared Library” from the Main
menu.
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Import the Sample Model
This tutorial will use Discovery and Exploitation of Resources as a sample model. If you didn’t finish it in
Tutorial 1 you can import it by following these steps.
1. Right-click on the Model Browser and select Import -> Model.
2. Find “sampleModels\Discovery And Exploitation Of Resources.sysdyn” in your SysDyn installation
folder and click Open.
Alternatively you can import the sample model by selecting “File -> Import Model” from the Main menu.

Activate the Simupedia Shared Libraries
Next we activate the Simupedia shared libraries for the sample model.
1.
2.
3.
4.

Select the Discovery and Exploitation of Resources model at the Model Browser.
Open the Selection view.
Select SimupediaSysdyn-1.0 from the list of Available libraries and click Use to activate it.
Select SysdynSimupedia from the list of Available libraries and click Use to activate it.
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Create a New Document
Next we create a new document. Document represents a single web page.
1. Expand the Discovery and Exploitation of Resources model at the Model Browser.
2. Right-click on Documentation and select “New -> Document”. The new document will appear as
“Document” under the Documentation tree.

3. Right click on Document and Select Rename. Then rename the document to “Main”.

Editing the Document
Next we open the Document Editor and the Document Viewer. Document Editor will show us the structure
of the web page as a graph consisting of various interconnected widgets. Document Viewer will show us
the preview of the actual web page.
1. Double-click the “Main” document to open it in a new Document Editor. You will see the Root
element under which we start building the document.
2. Open Document Viewer at “Window -> Show View -> Other… -> Documentation -> Document
Viewer”. At this point you will see only an empty web page.
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Containers
First we add a Vertical Panel to hold the contents of the web page. Vertical Panel is a Container that lays
out its child elements vertically on the web page in the same order as the corresponding terminals.
1. Open the Symbols view and expand Containers.
2. Drag Vertical Panel to the Editor View next to the Document’s Root element.
Then we connect the Vertical Panel to the Root element.
1.
2.
3.
4.

Hold down Alt.
Click the terminal in the Root element.
Click the terminal in the upper left corner of the Vertical Panel.
Release Alt.
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Then we add some styling for the panel.
1. Click the Vertical Panel widget and open the Selection view to edit the widget’s properties.
2. Set “Has Spacing?” to true. This will put extra spacing between the components contained by this
layout.
3. Enter 25px to Margin property. This will put a 25 pixel margin to all sides of the Vertical Layout.

Header
Next we add a title and a short description on top of the page.
1. Open the Symbols View and expand Primitive Widgets.
2. Drag two Label widgets next to the Vertical Panel.
3. Connect the Label widgets to the topmost terminals on the right side of the Vertical Panel.

Then we edit the contents of the Labels and do some basic styling.
1.
2.
3.
4.
5.

Click the first Label widget and open the Selection view.
Enter “Discovery and Exploitation of Resources” to the Text property (without quotation marks).
Edit the Font property and select Arial, Bold, 28 as the font.
Expand the Margin property and set 20px to Margin Bottom.
Click the second label and enter “Simulation based on Bossel, Hartmut (2007). System Zoo 2
Simulation Models. Climate, Ecosystems, Resources. BoD.” to its Text property.
6. Enter 30px to Margin Bottom for the second label.
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Now you can preview your first changes by opening the Document Viewer (Main). The page can be styled
further either by editing the widgets’ Layout And Style properties or by using Style Classes. The CSS style for
the document is defined at “Main (document) -> Selection -> CSS” tab.

Input Fields
Next we add input fields for each parameter. We will be using LabelAndValue and SliderAndValue widgets.
LabelAndValue widget consists of a label and a text field and SliderAndValue of a label and a slider. Each
instance of these widgets will be bound to a certain Sysdyn model parameter whose value it can then be
used to display and update.
1. Drag five copies of the LabelAndValue widget to the Document Editor next to the Vertical Panel.
You can find the widget from “Symbols -> Sysdyn Simupedia”.
2. Drag a LabelAndSlider widget to the Document Editor below the LabelAndValue widgets. You can
find the widget from “Symbols -> Sysdyn Simupedia”.
3. Connect the widgets from their left (blue) terminals to the Vertical Panel.
We leave the pink terminals unconnected at this point. Later they will be used to trigger automatic
simulation runs.
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Next we bind the input fields to corresponding model parameters and enter validation conditions, labels
and label widths.
1. Select the topmost LabelAndValue widget in the Document Editor and open the Selection view.
2. Enter “MAX DISCOVERABLE RESOURCES” as the Parameter (without quotation marks). This binds
the LabelAndValue widget to the matching model parameter.
3. Enter “Double(range=(0..))” as the Required Type. This means that the input field will accept only
values that are real numbers and larger than 0.
4. Enter “Max Discoverable Resources (Mio t)” as the label (without quotation marks). This label will
be shown on the web page.
5. Adjust the Label Width to 300px to reserve enough space for the label.
Similarly enter the properties for the remaining LabelAndValue and LabelAndSlider widgets according to
the following tables. (see the required type of MAX DISCOVERABLE RESOURCES does not allow 0)

Parameter

Required Type

1 MAX DISCOVERABLE RESOURCES Double(range=(0..))
2 MAX DISCOVERY RATE

Double(range=[0..))

3 INITIAL DISCOVERED RESOURCES Double(range=[0..))
4 MAX CONSUMPTION RATE

Double(range=[0..))

5 INITIAL CONSUMED RESOURCES

Double(range=[0..))

Parameter

Label

6 RECYCLED RESOURCE SHARE

Label

Label Width

Max Discoverable
Resources (Mio t)
Max Discovery Rate
(1 / Year)
Initial Discovered
Resources (Mio t)
Max Consumption
Rate (1 / Year)
Initial Consumed
Resources (Mio t)

300px

Label Width

Slider Width

300px
300px
300px
300px

Recycled Resource
300px
150px
Share (1)
The slider widget uses Min Value and Max Value instead of Required Type. Luckily the default values are
just right for this model.
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Line Charts
Next we add two line charts to visualize the simulation results. We will be using the Sysdyn LineChart
widget which automates the displaying of the results. We want to have the line charts side by side, so we
add them inside a Horizontal Panel widget.
1. Drag a Horizontal Panel widget to the Document Editor next to the Vertical Panel. You can find the
widget from “Symbols -> Containers”.
1. Connect the Horizonal Panel widget to the Vertical Panel.
2. Drag two copies of the LineChart widget to the Document Editor below the Horizontal Panel. You
can find the widget from “Symbols -> Sysdyn Simupedia”.
3. Connect the LineChart widgets to the Horizonal Panel.

Next we configure the left LineChart widget to show the values of the stocks and their difference.
1. Enter ["Discovered Resources","Consumed Resources","Available Resources"] to Variables
property. The names must match with the names of the model variables.
2. Enter 1.0 to Sample Period. This means that the line chart will be sampled in steps of 1 year.
3. Enter “Time (years)” to X Axis Name property.
4. Enter 480px to Width property.
5. Enter 300px to Height property.
Next we configure the right LineChart widget to show the values of the valves.
1.
2.
3.
4.
5.

Enter ["Discovery","Consumption"] to Variables property.
Enter 1.0 to Sample Period.
Enter “Time (years)” to X Axis Name property.
Enter 420px to Width property.
Enter 300px to Height property.
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Simulation Initialization
Next we add a simulation initializer to the document. Simulation initialization can be done automatically
when the web page is loaded or it can be triggered manually. In this example we will be using the
automatic initialization.
1. Drag an OnLoad widget to the Document Editor. You can find the widget from “Symbols -> Primitive
Events and data”.
2. Drag a Command Sequence widget to the Document Editor below the OnLoad Widget. You can find
the widget from “Symbols -> Primitive Events and data”.
3. Drag a SimulationInitialization widget to the Document Editor below the Command Sequence
widget. You can find the widget from “Symbols -> Sysdyn Simupedia”.
4. Connect the OnLoad widget to the topmost connection point in the Command Sequence widget.
This indicates that the command sequence will be triggered when the page is loaded.
5. Connect the Command Sequence widget from its leftmost bottom terminal to the
SimulationInitialization widget. This indicates that the simulation will be initialized automatically as
a first step when the page is loaded.
Note: We used a Command Sequence widget here because we want to trigger multiple events when the
page is loaded. We will connect a second event later.

Simulation Stepper
Next we add a simulation stepper and configure it to run the simulation automatically when the page is
loaded and whenever the user changes parameter values from the user interface.
1. Drag a SimulationStepper widget to the Document Editor next to the SimulationInitialization
widget. You can find the widget from “Symbols -> Sysdyn Simupedia”
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2. Connect the SimulationStepper widget to the second terminal in the bottom of the Command
Sequence widget. This indicates that the Simulation stepper will be run automatically after the
page has been loaded and the simulation initialized.
3. Connect the LabelAndValue widgets from their bottom (On value changed) terminals to the top
terminal in the SimulationStepper widget. This indicates that the simulation will be run
automatically on each value change.
4. Connect the SimulationStepper widget from its “Value updates before step” terminal to the
Vertical Panel’s pink bottom terminal. This indicates that the simulation stepper will fetch the input
values from the Vertical Panel’s child widgets and run the simulation with the updated parameter
values.
Note: Alternatively you could fetch individual values by connecting the SimulationStepper to
selected rightmost terminals of LabelAndValue and SliderAndValue widgets. This would also require
the use of a Command Sequence.

Tip: You can adjust the routing of the connection lines by dragging the lines with left mouse button pressed
down.
Next we configure the SimulationStepper to run the simulation for 200 time units (years) whenever the
simulation is run.
1. Enter 200.0 to Simulation Duration property.
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Run the Simulation
You have now finished your first document. It’s time to see how it works.
1. Open the Main document in the Document Viewer.
(Show Document Viewer: “Window -> Show View -> Other… -> Documentation -> Document
Viewer”)
2. Enter values for the parameters.
3. See the results of the simulation in the line charts.

You can also view the web page in a web browser of your choice. Right click in the Document Viewer and
select Properties. Copy the “Address (URL)” field from the dialog into the address field of your browser.
The finished model can also be downloaded from http://www.simupedia.com.

Tutorial 3 – Initial Conditions
In this tutorial we will get familiar with widgets that load, save and delete the initial conditions of the
experiment (i.e. the values of the parameters). With these widgets it’s easy to share interesting initial
conditions to the users and between the users.
The initial conditions loader and saver are available as dialog based and non-dialog based widgets. We will
learn to use the dialog based ones in this tutorial.
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Preparations
This tutorial will use the end result of Tutorial 2 as a starting point. If you skipped Tutorial 2 you should start
by importing the shared library and the finished model from Tutorial 2. Make also sure that you have the
Simupedia plug-in installed (as described in Tutorial 2).
1. Download and import SysdynSimupedia.sharedLibrary from http://www.simupedia.com.
2. Download and import the finished Tutorial 2 model from http://www.simupedia.com.

Dialog based Initial Conditions Loader/Saver
The initial conditions can be loaded and deleted by using the ICLoaderDialog widget and saved and deleted
by using the ICSaverDialog widget. It’s possible to disable the delete functionality if it’s not desired. Let’s
learn how to use these widgets.
First we create a horizontal layout and add buttons that will open the dialogs.
2. Drag a Horizontal Panel widget to Document Editor below the Vertical Panel widget. You can find
the widget from Symbols -> Containers.
3. Connect the Horizontal Panel widget from its top left terminal to the Vertical Panel widget
4. Edit the properties of the Horizontal Panel widget and set “Has Spacing?” to true. This will put
some extra spacing between the buttons.
5. Drag two Button widgets below the Horizontal Panel widget. You can find the Button widget from
“Symbols -> Primitive Events and data”.
6. Connect the Button widgets to the Horizontal Panel widget from their blue terminals
7. Edit the properties of the buttons and enter “Load Initial Conditions” as the Text property for the
left button and “Save Initial Conditions” as the Text property for the right button.

Then we add the ICLoaderDialog and ICSaverDialog widgets and link them with the buttons that we
created. We also configure the ICLoaderDialog to run the simulation automatically when the user loads
initial conditions.
1. Drag ICLoaderDialog widget and ICSaverDialog widgets below the buttons. You can find these from
“Symbols -> Sysdyn Simupedia”.
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2. Connect the Button widgets from their pink terminals to the top (Trigger) terminals of the
ICLoaderDialog and ICSaverDialog widgets. This indicates that the corresponding dialog will be
opened when the button is pressed.
3. Connect the ICLoaderDialog widget from its bottom (On Load) terminal to the top (Run) terminal of
the SimulationStepper widget. This indicates that the simulation will be automatically run after the
initial conditions have been loaded.

The initial conditions loader/saver dialogs are now ready to be used. Let’s see the end results in the
Document Viewer.
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The finished model can also be downloaded from http://www.simupedia.com.

Non-dialog based Initial Conditions Loader/Saver
The initial conditions can be controlled also with non-dialog based widgets. With the ICComboBox widget
the user can straightforwardly select the initial conditions to load. This is usually a good approach if you
provide only predefined initial conditions. The ICControls widget has the same functionality as the dialog
based widgets, but it can be directly attached to the document.
You can experiment with these widgets by simply dragging them to the Document editor and connecting
them to the layout. Don’t forget to trigger the Simulation Stepper from the “On Load” terminal if you want
to run the simulation automatically.
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